CSLAIERでTensorFlow

CSLAIERにはTensorFlowも選べる.ドキュメントによるとTensorFlowのバージョンは0.11までとなっている.しかし,TensorFlowのサイトにあるバージョンは今は0.12~1.2だけだ.ダメもとで1.2を入れてみた.

sudo pip install tensorflow

CSLAIERでTensorFlowを選んで走らせてみると,やっぱりエラーになった.CSLAIERは古すぎて使えないというのが結論だ.deep learningで遊ぶのなら他の遊び方を考えた方がよさそうだ.

広告

CSLAIERでChainer

CSLAIERでChainer2.0.0を動かしていたんだが,学習が終わらない.ソースの変更が間違っているのじゃないかという気がしてきた.Chainerをversion1に戻してやり直し.GPUを持っていないのでまたしばらく待つことになる.

$sudo pip uninstall chainer

$sudo pip install chainer==1.8.1

でバージョンが1に戻る.

で,待つこと13時間.学習が完了した.inspectすると,確かに正しく識別している.